miércoles, 5 de marzo de 2008

VLAN 1

Para iniciarse con la programación de dispositivos, ya sea routers ó switches, siempre es bueno dominar la configuración de una VLAN (virtual LAN). Este ejemplo simple sirve para tal propósito.En este ejemplo se podrá analizar y copmprender la configuración del switch y el enrutamiento en el router, para la comunicación entre VLANs.

(Packet Tracer 4.11, Cisco Systems, Inc.)



Router 2621XM

En el router asignaremos las sub-interfaces fastethernet 0/0.X, y las relacionaremos con una VLAN. Por ejemplo, VLAN 2 tendrá como sub-interfaz en el router la direccion IP 192.168.1.1, por defecto, la VLAN 3 con IP 192.168.2.1.
Es muy importante indicar el tipo de encapsulamiento (dot1q) con el número de la VLAN.

Router>enable
Router#config t
Router(config)#interface fastethernet 0/0.1
Router(config-subif)#encapsulation dot1q 2
Router(config-subif)#ip address 192.168.1.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fastethernet 0/0.2
Router(config-subif)#encapsulation dot1q 3
Router(config-subif)#ip address 192.168.2.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fastethernet 0/0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#exit
Router#copy run start


*Nótese que las sub-interfaces se encuentran en diferentes subredes, para cada VLAN.
*La conexión física del router hacia el switch es por la interfaz F0/0

Host

Los host pertenecientes a una VLAN deben tener como dirección IP la misma direccion de subred, siendo diferente para cada VLAN. Y con referente al GATEWAY debe ser la misma direccion IP de la subinterface a la que pertenece su VLAN configurado en el router.

Ejemplo:
Host A (IP 192.168.1.11) pertenece al VLAN 2, entonces el GATEWAY es 192.168.1.1, y el host B (IP 192.168.2.12) pertence al VLAN 3, entonces su GATEWAY es 192.168.2.1.



Switch 2960

La configuracion del switch es importante para la creación de VLANs, los cuales no se van a ver. También hay que tomar en cuenta que el modo TRUNK en la interfaz F0/1.


Switch>enable
Switch#config t
Switch(config)#vlan 2
Switch(config-vlan)#name Electronica
Switch(config-vlan)#exit
Switch(config)#vlan 3
Switch(config-vlan)#name Economia
Switch(config-vlan)#exit
Switch(config)#int f0/2
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#int f0/3
Switch(config-if)#switchport access vlan 3
Switch(config-if)#exit
Switch(config)#int f0/4
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#int f0/5
Switch(config-if)#switchport access vlan 3
Switch(config-if)#exit
Switch(config)#int f0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allow vlan all
Switch(config-if)#exit
Switch(config)#exit
Switch#copy run start

*La connexion entre el switch y el router se ha configurado por la interfaz F0/1 del switch.

9 comentarios:

Anónimo dijo...

Genial...me ayudo mucho tu blog...mil...y mil ...gracias..muaaaa

Anónimo dijo...

es muy bueno tu ejemplo no sabia como empesar a hacer una VLAN y ahora ya estoy por realizar una red mas grande, quisiera pedirte por favor si podrias poner comentario en la configuracion de cada linea del router y el switch para poderlo entender mejor... GRACIAS por tu colaboracion

moan dijo...

Hola, muy claro el post.
No es necesario aclarar la red de la vlan en el switch?
osea aclarar en el switch que vlan1 es la red 192.168.1.0/24 y la vlan2 es la red 192.168.2.0/24???
o configurando las interfaces del router alcansa?

RODOCISCO dijo...

Gracias por el comentario 'moan'.
El switch es un dispositivo de Capa 2, y no es necesario la asignacion de direcciones IP. Solo basta asociar a cada host la VLAN correspondiente en el switch. Además de configurar el router.

avlasor dijo...

Muy buena la entrada.

Tengo una duda, nosotros estamos intentando implantar voip en la oficina, y queremos que la voz vaya por una vlan y los datos por otra. Hasta ahí bien, el caso es que en los pcs habrán instalado softphones, y tendrán dos ips distintas una para la vlan de datos y otra para de voz. He visto que en las configuraciones de los switchs se indica que un puerto pertenece a una vlan pero en nuestro caso en un puerto (al que se conecta el pc) van datos de dos vlans distintas. ¿Cómo se puede configurar el swicths para indicarle que una ip pertence a una vlan?

Anónimo dijo...

quiza sea tarde, pero como puede configurar para que netre vlans no se puedan comunicarse, ejemplo. tengo tres switches cada una con tres vlan 10,20,30 la vlan 10 es el Administrador y el solo pude ver a los demas, pero entre la 20 y 30 no.

Anónimo dijo...

gracias es un ejemplo muy claro. que nos a ayudado a muchos

Anónimo dijo...

Hola, felicidades por el tutorial!!!!

MUY BUENO!!!

Anónimo dijo...

avlasro aqui va mi respuesta lo que tu quierers hacer es que por un purto del switch vyan 2 vlan una para data y otro para voz y sera del sgte modo:

switchport mode trunk
switchport trunk native vlan (de PC)
switchport trunk allowed vlan (de voz)

Publicar un comentario en la entrada

Si tienes alguna duda o algún aporte déjalo en este espacio y si gustas dejame tu correo para responderte personalizadamente

Búsqueda personalizada